Phonism.com Marketing Site
Incident Report for Phonism
Resolved
The Phonism.com site is up and fully functional.

No core services were impacted. ( Admin Portal / Phone Provisioning / API )
Posted Nov 17, 2020 - 16:25 EST
Investigating
Our marketing site is currently inaccessible, or slow to load. We are currently Investigating.

The admin portal remains available at https://app.phonism.com for US and https://app.euw1.phonism.com for EU.

No other services are affected ( Admin Portal / Phone Provisioning / API )
Posted Nov 17, 2020 - 13:20 EST
This incident affected: Phonism.com Marketing Portal.