Degraded Performance on Admin Portal
Incident Report for Phonism
Resolved
We have not seen any additional issues with responsiveness in our Admin Portal, and consider the issue to be resolved.
Posted Oct 20, 2020 - 17:48 EDT
Monitoring
We have implemented a change that improves portal performance and responsiveness. We are monitoring for any additional issues and will update once we are satisfied.

No other services are or were impacted (Device Provisioning/API)
Posted Oct 20, 2020 - 16:25 EDT
Identified
One of our External Vendors is experiencing high error rates and latency with their API's, affecting the responsiveness of our Admin Portal.

We are investigating further and implementing a workaround.

No other services are impacted at this time (Phone Provisioning/API)
Posted Oct 20, 2020 - 15:22 EDT
Investigating
Some users are experiencing slow navigation and difficulty with operations inside our portal at this time. We are investigating and will provide an update shortly.
Posted Oct 20, 2020 - 15:07 EDT
This incident affected: Phonism United States (Admin Portal) and Phonism Europe (Phonism Admin Portal).